Searching for Individuals are not loading
Incident Report for Remind
Resolved
We are continuing to work on a fix for this issue.
Posted Oct 28, 2021 - 13:27 PDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 28, 2021 - 13:00 PDT
Identified
We are currently experiencing issues with the people list not loading as intended. We are actively investigating and working to resolve the performance issues. Thank you for your patience
Posted Oct 28, 2021 - 12:56 PDT
This incident affected: Website, iOS App, and Android App.