Remind Slowdown 8/24
Incident Report for Remind
Resolved
This incident has been resolved.
Posted about 2 years ago. Aug 24, 2017 - 17:56 PDT
Investigating
Remind users may experience slow load times due to high site volume! We're working to get it back to full speed.
Posted about 2 years ago. Aug 24, 2017 - 15:37 PDT