Remind Slowdown 8/13
Incident Report for Remind
Resolved
This incident has been resolved.
Posted about 1 year ago. Aug 13, 2018 - 15:04 PDT
Identified
Some users might see slow load times and intermittent slowdowns on the app and on web.
Posted about 1 year ago. Aug 13, 2018 - 14:16 PDT
This incident affected: Website and Mobile Apps and Text and Email Messages.