Remind Site Slowdown
Incident Report for Remind
Resolved
This incident has been resolved.
Posted about 2 years ago. Aug 28, 2017 - 15:41 PDT
Investigating
Due to high traffic Remind will be a little slow for some users. Scheduled messages might go out 2-5 minutes late. We're working on getting it back up to full speed!
Posted about 2 years ago. Aug 28, 2017 - 13:14 PDT