Remind errors
Incident Report for Remind
Resolved
This incident has been resolved! So sorry for any inconvenience caused.
Posted Jul 10, 2020 - 08:05 PDT
Investigating
Remind is currently experiencing performance issues that may be causing errors for you as you use Remind. We are actively investigating and working to resolve the issues. We apologies for the inconvenience caused!
Posted Jul 10, 2020 - 07:52 PDT
This incident affected: Website, Text Messages (SMS), iOS App, Android App, Email Messages, Voice Messages, Website and Mobile Apps, and Text and Email Messages.