Remind Outage
Incident Report for Remind
Resolved
Remind is back up and running. So sorry for any inconvenience caused!
Posted Sep 25, 2020 - 07:38 PDT
Investigating
The Remind service is currently experiencing some downtime. We hope to be fully back up and running as soon as possible and apologize for the inconvenience!
Posted Sep 25, 2020 - 07:28 PDT
This incident affected: Voice Messages, Website and Mobile Apps, and Text and Email Messages.