Degraded Performance
Incident Report for Remind
Resolved
This incident has been resolved.
Posted Apr 11, 2022 - 16:02 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 11, 2022 - 15:54 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 11, 2022 - 15:32 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 11, 2022 - 15:32 PDT
Investigating
We are currently experiencing Remind pages not loading fully. We are actively investigating and working to resolve the performance issues. Thank you for your patience
Posted Apr 11, 2022 - 15:23 PDT
This incident affected: Website.